SapphireSteel Forum
Welcome, Guest. Please login or register.
July 20, 2017, 10:34:02 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the SapphireSteel forum - for discussion of the Sapphire and Amethyst IDEs
4074 Posts in 848 Topics by 708 Members
Latest Member: dcham_inbsys
* Home Help Search Login Register
+  SapphireSteel Forum
|-+  General
| |-+  Sapphire / Ruby In Steel
| | |-+  Visual Studio Shell 2013 Closes Current Window with Char+Underscore
« previous next »
Pages: [1] Print
Author Topic: Visual Studio Shell 2013 Closes Current Window with Char+Underscore  (Read 2684 times)
glindstr
Newbie
*
Posts: 4


« on: January 28, 2015, 09:33:10 AM »

I have an issue with visual studio 2013 closes windows when certain key combinations are entered. Reproducible example on my machine and setup:

in any rb file on a new line, type this quickly:

t_

The current rb file window will close itself. It seems like any letter + underscore closes the window. I thought this might have to do with windows accessibility options but i turned them all off so I don't understand what's going on. This was never an issue for me on visual studio 2011 with RiS 2. Is this happening on anyone elses machine? Its driving me crazy.
Logged
Dermot
Administrator
Hero Member
*****
Posts: 1068


« Reply #1 on: January 28, 2015, 04:24:14 PM »

Yes it does.

in VS2010, MS introduced a new editor and to enable compatibility with the old code, they introduced a set of 'shims' that allowed the old code (VS2008 and older) to interface with the new code in VS2010. However, some shims don't work quite as expected in VS2012 and VS 2013. The key sequence works as expected in VS2010, but not in VS2012 & 2013. We had noticed some strange behaviour around the '_' character in VS2013 but we hadn't noticed this particular problem.

The problem only occurs in completion lists and in particular in dismissing a completion list because of a character mismatch. You can mismatch with any character apart from '_' and  it works OK: the completion list goes. With an '_' strange things happen. It's only with an '_' - all other characters work OK. No idea why - it's not our code that does this.

You can stop this behaviour by going to Tools | Options | Text Editor | Ruby | Intellisense and unchecking 'Dismiss the completion list when a character mismatch occurs'.

We'll have to think about how to fix this, but it looks like we'll have to implement the completion lists using the new editor rather than using the shims. I don't think MS are going to be interested in investigating or fixing this one somehow.

Dermot
Logged
glindstr
Newbie
*
Posts: 4


« Reply #2 on: January 28, 2015, 06:57:36 PM »

Thanks for the reply Dermont. This is quite interesting. I'll turn off the feature and hope the lack of dismiss doesn't drive me crazy.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!