SapphireSteel Forum
Welcome, Guest. Please login or register.
September 20, 2017, 04:51:28 AM

Login with username, password and session length
Search:     Advanced search
Welcome to the SapphireSteel forum - for discussion of the Sapphire and Amethyst IDEs
4074 Posts in 848 Topics by 708 Members
Latest Member: dcham_inbsys
* Home Help Search Login Register
+  SapphireSteel Forum
|-+  General
| |-+  Amethyst
| | |-+  Amethyst 'Edge' release for Visual Studio 2010
« previous next »
Pages: [1] Print
Author Topic: Amethyst 'Edge' release for Visual Studio 2010  (Read 6391 times)
Huw Collingbourne
Administrator
Hero Member
*****
Posts: 947



« on: May 03, 2010, 04:47:10 AM »

Our first public version of Amethyst for Visual Studio 2010 is now available for testing. This is an 'edge' release which means that it is an interim build rather than a full beta. We use edge releases to introduce new features which may not be as fully tested as the features in our major betas. We recently released our final full beta prior to our first release candidate. We may release 1 or more 'edge' releases before the release candidate. Amethyst for VS2010 may be installed on the same PC as an installation of Amethyst for VS2008.

As always, we value all user feedback on the releases of Amethyst. However, take all reasonable caution and do not use it with critical code (unless you have a backup!).

We are aware of the following problems with the VS2010 release of Amethyst:

1) SmartTags do not work. So, while a small 'tag' may appear when you rename a variable, for example, you cannot click the tag to display the Refactor dialog. Workaround: right-click an identifier and select 'Refactor' from the menu.
2) The snippet directory is wrong. Solution: select Tools/Code Snippet manager and browse to the correct snippet directory which is located under your Amethyst directory (typically under Program Files).
3) VS may crash if you spilt the editor screen and then try to use the drop-down Navigation bar above the editor. Avoid this sequence of actions!

Download here: http://www.sapphiresteel.com/downloads/amethyst_beta_893_VS2010.zip
Logged
GoDanno
Registered User
Newbie
*
Posts: 5


« Reply #1 on: May 03, 2010, 01:39:24 PM »

Hello,

I installed Amethyst for VS 2010 on a clean virtual machine with Visual Studio 2010 installed (Visual Studio 2008 is not installed). However, when I attempt to create a new Flex 3 Application, Visual Studio displays the following error:

Error: this template attempted to load component assembly 'AmethystWizard, Version=1.0.0.0, Culture=Neutral, PublicKeyTokey=8a42f26dbbcba2be'. For more information on this problem and how to enable this template, please see documentation on Customizing Project Templates.

After poking around a little bit, I found that the version of the AmethystWizard assembly in the GAC is 2.0.0.0, not 1.0.0.0.

Virtual Machine stats:
VMware Workstation host
Windows 7 Ultimate 64-bit
Visual Studio 2010 RTM
Flex SDK 3.5a
No previous installations of Amethyst or Visual Studio 2008

Thanks,
Dan
Logged
Dermot
Administrator
Hero Member
*****
Posts: 1068


« Reply #2 on: May 03, 2010, 03:54:49 PM »

Thanks ...

The templates got slightly screwed up in the build. I've uploaded a new beta with the template versions set to 2.0.0.0. The 1.0.0.0 are the 2008 ones. There's actually no difference, but for SxS operation, I need to distinguish between the wizards.

Dermot
Logged
GoDanno
Registered User
Newbie
*
Posts: 5


« Reply #3 on: May 03, 2010, 06:08:37 PM »

Thanks Dermot. It works now.

Best regards,
Dan
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!