SapphireSteel Forum
Welcome, Guest. Please login or register.
June 25, 2017, 02:48:20 PM

Login with username, password and session length
Search:     Advanced search
Welcome to the SapphireSteel forum - for discussion of the Sapphire and Amethyst IDEs
4074 Posts in 848 Topics by 708 Members
Latest Member: dcham_inbsys
* Home Help Search Login Register
+  SapphireSteel Forum
|-+  Recent Posts
Pages: [1] 2 3 ... 10

 1 
 on: January 28, 2015, 06:57:36 PM 
Started by glindstr - Last post by glindstr
Thanks for the reply Dermont. This is quite interesting. I'll turn off the feature and hope the lack of dismiss doesn't drive me crazy.

 2 
 on: January 28, 2015, 04:24:14 PM 
Started by glindstr - Last post by Dermot
Yes it does.

in VS2010, MS introduced a new editor and to enable compatibility with the old code, they introduced a set of 'shims' that allowed the old code (VS2008 and older) to interface with the new code in VS2010. However, some shims don't work quite as expected in VS2012 and VS 2013. The key sequence works as expected in VS2010, but not in VS2012 & 2013. We had noticed some strange behaviour around the '_' character in VS2013 but we hadn't noticed this particular problem.

The problem only occurs in completion lists and in particular in dismissing a completion list because of a character mismatch. You can mismatch with any character apart from '_' and  it works OK: the completion list goes. With an '_' strange things happen. It's only with an '_' - all other characters work OK. No idea why - it's not our code that does this.

You can stop this behaviour by going to Tools | Options | Text Editor | Ruby | Intellisense and unchecking 'Dismiss the completion list when a character mismatch occurs'.

We'll have to think about how to fix this, but it looks like we'll have to implement the completion lists using the new editor rather than using the shims. I don't think MS are going to be interested in investigating or fixing this one somehow.

Dermot

 3 
 on: January 28, 2015, 09:33:10 AM 
Started by glindstr - Last post by glindstr
I have an issue with visual studio 2013 closes windows when certain key combinations are entered. Reproducible example on my machine and setup:

in any rb file on a new line, type this quickly:

t_

The current rb file window will close itself. It seems like any letter + underscore closes the window. I thought this might have to do with windows accessibility options but i turned them all off so I don't understand what's going on. This was never an issue for me on visual studio 2011 with RiS 2. Is this happening on anyone elses machine? Its driving me crazy.

 4 
 on: January 27, 2015, 08:39:47 AM 
Started by glindstr - Last post by glindstr
Great. Thank you.

 5 
 on: January 24, 2015, 12:37:13 PM 
Started by glindstr - Last post by Dermot
Thanks for the bug report.

We've reproduced the problem and it is a bug in Sapphire. A structure is not being initialized under some circumstances and a null value is being passed to Visual Studio COM code which is objecting. The real problem is that the code that calls the COM interface isn't surrounded by a try-catch and that's what's causing VS to bomb.

We're planning to fix it (and several other bugs which have been reported)  in the next release of Sapphire (v3.1) which we're targeting for after the VS 2015 release.

Dermot

 6 
 on: January 23, 2015, 10:39:49 AM 
Started by glindstr - Last post by glindstr
I'm not sure what's wrong with my configuration or perhaps its a bug. Visual Studio Shell 2013 Crashes when hovering over some variables at breakpoints. I'm using Ruby 1.9.3, Sapphire 3.0.1.1620, VS Shell 2013 12.0.30723.00 Update 3.

Example code
----------------------
require "time"

foo = "bar"
test = DateTime.now.new_offset(0).strftime('%Y-%m-%dT%H:%M:%SZ')

puts DateTime.now.new_offset(0).strftime('%Y-%m-%dT%H:%M:%SZ')
puts (DateTime.now+1/100.0).new_offset(0).to_s
-------------------------------

I set a breakpoint at "puts (DateTime.now+1/100.0).new_offset(0).to_s". I run the code to the breakpoint. I mouse over (for tooltip) on "foo" which works and also on "test" works. If I mouse over on "DateTime" of line "puts DateTime.now.new_offset(0).strftime('%Y-%m-%dT%H:%M:%SZ')" VS will hard crash with "Microsoft Visual Studio 2013 has stopped working" choose to Debug or close program. Debug says "An unhandled Microsoft .NET Frameowrk exception occurred in devenv.exe [8484]".

I don't actually need the tooltip for DateTime but when my mouse hovers over some code by chance randomly when debugging VS crashes which is extremely disruptive.

I don't think this tooltip issue has ever worked for me. Any ideas what the problem is?

Greg

 7 
 on: September 15, 2014, 08:52:09 AM 
Started by poco - Last post by poco
That is unfortunate!! I know that this isn't a suggestion forum but a feature to make .so files would be an excellent feature of Sapphire or an add on option. I always have frustrating problems using "make" and "gcc".  Seem to always gets errors of file or rule not found. Almost all instructions stop at --- then just use make --- worthless.

I don't think I am alone. This is an area Sapphire should consider as there is a great demand in that Ruby is growing in acceptance now.  If not Sapphire, than somebody else will fill the void?

 8 
 on: September 14, 2014, 11:50:21 AM 
Started by poco - Last post by Dermot
Hi,

There are three .so files distributed with Sapphire. Two are the Cylon debugger Ruby plug-ins which are really not usable by anything other than Sapphire.

The third one is a the RubyForms 'shim' which allows Ruby to work with Flash. This can be used from standalone Ruby programs, but it's really designed to be used with the generated Ruby and ActionScript files in a RubyForms project.

Dermot

 9 
 on: September 13, 2014, 12:21:35 PM 
Started by poco - Last post by poco
Just installed upgrade to #3  in VS 2013-- i notice in the compile process, it is creating a "so" file -- (forget the utility used-- maybe Ceylon??)

But if so, can that "so" file be used as a RUBY add-in? Can't find the "so" file anywhere to try? If so -- does it have to be 32 - bit version?

VS 2013, win 7 - 64 bit, Ruby 1.9.3

 10 
 on: September 09, 2014, 02:28:49 PM 
Started by Dermot - Last post by Dermot
Amethyst 2.2.0.1622 is now available for download

The Visual Studio 2010 version is http://www.sapphiresteel.com/downloads/amethyst_VS2010_2_2_0.zip

The Visual Studio 2012 version is http://www.sapphiresteel.com/downloads/amethyst_VS2012_2_2_0.zip

The Visual Studio 2013 version is http://www.sapphiresteel.com/downloads/amethyst_VS2013_2_2_0.zip

Supports:

a) Visual Studio 2010,2012 and 2013 with no change in project files
b) Adobe Flex 4.6; Apache Flex 4.8, 4.9, 4.10, 4.11, 4.12, 4.13
c) Flash Player 14.0
d) AIR 14.0
e) iOS 5/6 and Android 4 deployment and debugging

Pages: [1] 2 3 ... 10
Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!