Installation

Back to -Products -Sapphire-IDE -FAQ -Installation

What Prerequisites Do I Need To Install for Ruby In Steel?

What software do I need to install in order run Ruby In Steel 1.5?

Ruby In Steel 2.0 requires a commercial edition of Visual Studio 2010 or a free ‘Shell’ edition of Visual Studio 2010. It supports Ruby 1.8.6, Ruby 1.9.2 and Rails 3. While it is possible that other software versions may be supported, we do not guarantee this.

Ruby In Steel 1.5 requires a commercial edition of Visual Studio 2005 or 2008 or a free ‘Shell’ edition of Visual Studio. It supports Ruby 1.8.6, JRuby 1.4, Rails 1 and Rails 2. While it is possible that other software versions may be supported, we do not guarantee this.

If you wish to install a free edition of Visual Studio, either use our All-in-one installer or download the Visual Studio Shell from Microsoft. You cannot install into Visual Studio Express. For more on installing a free edition of Visual Studio see this FAQ.

When installing Ruby In Steel, be sure to run the supplied Setup.exe and not an MSI file. For more on installation problems see, this FAQ.

To be sure of installing a supported version of Ruby, go to our Ruby In Steel Prerequisites Page.

To install Rails 2 (for Ruby In Steel 1.5 only), run this command at the commandline:

gem install rails --version=2.3.8

Bookmark and Share   Keywords:  Ruby In Steel 1
© SapphireSteel Software 2014