Installation

Back to -Products -Sapphire-IDE -FAQ -Installation

Can’t install under Vista. Error 2869

When I try to install Ruby In Steel under Vista, the installer keeps reporting an ‘unexpected error’ Number 2869.

Error #2896 is a frequently reported error for ‘msi’ installation programs installed under Vista. The full error message typically reads:

"The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2869"

This may occur when Vista’s User Access Controls fail to grant the user full administration rights when installing a program. A simple way around this is to run the setup from a command prompt with administrator privileges. To do this, click the Windows Start button and navigate to the Accessories program group. Right-click ‘Command prompt’ and select ‘Run as administrator’. Now navigate to the directory containing your Ruby In Steel installation files and execute this command:

msiexec /i SteelPackage.msi

Notes:

- Only use the installation method if you have previously experienced problems. We advise most users to install Ruby In Steel using Setup.exe rather than by running specific msi programs.

- You also need to have the Project Aggregator installed before you can create and load Ruby In Steel projects. This is installed automatically when you run Setup.exe. However, if you have installed Ruby In Steel using an msi rather than the default Setup program you may need to install the Project Aggregator yourself. For more information, please read this FAQ.

© SapphireSteel Software 2014